Ir para conteúdo

Alerta de Vulnerabilidade - Samba > 3.5.0

TIPO
Vulnerabilidades
SISTEMAS AFETADOS
Samba > 3.5.0
ECOSSISTEMA
Linux
Descrição

Todas as versões de Samba a partir da versão 3.5.0 estão vulneráveis a execução remota de código.
Esta vulnerabilidade permite que um cliente malicioso realize um upload de um biblioteca partilhada para uma partilha com permissões de escrita, sendo depois carregada e executada no servidor.



Impacto

Um atacante remoto consegue obter privilégios de sistema na máquina alvo ou correr qualquer outro tipo de código malicioso.



Rsolução

Deve ser instalado um patch para esta vulnerabilidade:
- http://www.samba.org/samba/security/

(CVE-2017-7494, data: 24-May-2017)


Para as versões de Samba 4.6.4, 4.5.10 e 4.4.14 foi lançado um patch de segurança para corrigir esta falha.

Patches para versões mais antigas podem ser consultadas em:
http://samba.org/samba/patches/

 



Referências

Samba:
- https://www.samba.org/samba/security/CVE-2017-7494.html


- https://www.samba.org/samba/history/security.html

 

Naked Security:
- https://nakedsecurity.sophos.com/2017/05/26/samba-exploit-not-quite-wannacry-for-linux-but-patch-anyway/

 

Comman Vulnerabilities and Exposures:
- http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7494

 

Última atualização em 13-12-2020